Задание №4455. Все четырёхбуквенные слова, в составе которых могут быть буквы А, В, Л, О, С, записаны в алфавитном порядке и пронумерованы начиная с 1. Ниже приведено начало списка. 1. АААА 2. АААВ 3. АААЛ 4. АААО 5. АААС 6. ААВА … Под каким номером в списке идёт первое слово, которое начинается с буквы Л?


Задание №4455.
Измерение количества информации. ЕГЭ по информатике

Все четырёхбуквенные слова, в составе которых могут быть буквы А, В, Л, О, С, записаны в алфавитном порядке и пронумерованы начиная с 1.

Ниже приведено начало списка.
1. АААА
2. АААВ
3. АААЛ
4. АААО
5. АААС
6. ААВА


Под каким номером в списке идёт первое слово, которое начинается с буквы Л?

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('АВЛОС', repeat=4)))

for x in range(len(collection)):
    if collection[x][0] == 'Л':
        print(x+1)
        break

Таким образом, первое слово, которое начинается с буквы Л идет в списке под номером 251.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями