Задание №4456. Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых ровно одна цифра 6, при этом никакая нечётная цифра не стоит рядом с цифрой 6.


Задание №4456.
Измерение количества информации. ЕГЭ по информатике

Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых ровно одна цифра 6, при этом никакая нечётная цифра не стоит рядом с цифрой 6.

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('01234567', repeat=5)))

count = 0
for number in collection:
    if number[0] != '0' and number.count('6') == 1:
        if number.find('6') == 0 and int(number[number.find('6')+1]) % 2 == 0:
            count += 1
        elif number.find('6') == 4 and int(number[number.find('6')-1]) % 2 == 0:
            count += 1
        elif number.find('6') != 0 and number.find('6') != 4 and int(number[number.find('6')+1]) % 2 == 0 and int(number[number.find('6')-1]) % 2 == 0:
            count += 1
print(count)

Таким образом, существует 2961 пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых ровно одна цифра 6, при этом никакая нечётная цифра не стоит рядом с цифрой 6.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями