Задание №4457. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей вещественные числа – результаты ежечасного измерения температуры воздуха в течение трёх месяцев. Найдите, на какое максимальное количество градусов понизилась температура воздуха с 11:00 до 12:00 в мае, используя данные, представленные в таблице. В ответе запишите только целую часть числа.


Задание №4457.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей вещественные числа – результаты ежечасного измерения температуры воздуха в течение трёх месяцев. Найдите, на какое максимальное количество градусов понизилась температура воздуха с 11:00 до 12:00 в мае, используя данные, представленные в таблице.

В ответе запишите только целую часть числа.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

with open('input.txt', encoding='utf-8') as weather_data:
    weather_data = weather_data.read().splitlines()[1:]
    difference = []
    for line in weather_data:
        line = [i.replace(',','.') for i in line.split('\t')]
        if '.05.' in line[0]:
            difference.append(float(line[12]) - float(line[13]))
print(max(difference))

Таким образом, 2,6 — максимальное количество градусов, на которое понизилась температура воздуха с 11:00 до 12:00 в мае. В ответе записываем только целую часть — 2.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями