Задание №4459. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия: – в строке есть два числа, каждое из которых повторяется дважды, остальные три числа различны; – среднее арифметическое неповторяющихся чисел строки больше среднего арифметического всех её повторяющихся чисел. В ответе запишите только число.


Задание №4459.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия:

– в строке есть два числа, каждое из которых повторяется дважды, остальные три числа различны;

– среднее арифметическое неповторяющихся чисел строки больше среднего арифметического всех её повторяющихся чисел.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

count = 0

with open('input.txt') as numbers:
    numbers = numbers.read().splitlines()
    for line in numbers:
        line = [int(i) for i in line.split('\t')] # список, в котором хранятся числа строки
        repetitions = [line.count(line[i]) for i in range(len(line))] # количество повторений каждого числа в строке
        
        mean_line = sum(line) / len(line) # среднее всех чисел в строке

        try:
            mean_non_repitions = sum(line[i] for i in range(len(line)) if repetitions[i] == 1) / len([i for i in repetitions if i == 1])
        except ZeroDivisionError:
            continue

        if sum(repetitions) == 11 and mean_non_repitions > mean_line:
            count += 1
        
print(count)

Таким образом, 96 строк таблицы соответствуют указанным в задании условиям.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями