Задание №4460. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия: – в строке все числа различны; – удвоенная сумма максимального и минимального чисел строки не больше суммы оставшихся трёх её чисел. В ответе запишите только число.

Задание №4460.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке все числа различны;

– удвоенная сумма максимального и минимального чисел строки не больше суммы оставшихся трёх её чисел.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

count = 0

with open('input.txt') as numbers:
    numbers = numbers.read().splitlines()
    for line in numbers:
        line = sorted([int(i) for i in line.split('\t')])
        
        if len(line) == len(set(line)) and sum([line[0], line[-1]]) * 2 <= sum(line[1:4]):
            count += 1
    print(count)

Таким образом, 607 строк таблицы соответствуют указанным в задании условиям.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями