Задание №4461. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей вещественные числа – результаты метеорологических измерений в течение второго полугодия 2019 года. Найдите разность между средними значениями среднесуточной температуры (°С) воздуха в августе и ноябре, используя данные, представленные в таблице. В ответе запишите только целую часть получившегося числа.

Задание №4461.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей вещественные числа – результаты метеорологических измерений в течение второго полугодия 2019 года. Найдите разность между средними значениями среднесуточной температуры (°С) воздуха в августе и ноябре, используя данные, представленные в таблице.

В ответе запишите только целую часть получившегося числа.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

with open('input.txt', encoding='utf-8') as weather_data:
    weather_data = weather_data.read().splitlines()[1:]
    august = []
    november = []
    for line in weather_data:
        line = [i.replace(',','.') for i in line.split('\t')]
        if '.08.' in line[0]:
            august.append(float(line[3]))
        elif '.11.' in line[0]:
            november.append(float(line[3]))
print((sum(august) / len(august)) - (sum(november) / len(november)))

Таким образом, 28,4 — разность между средними значениями среднесуточной температуры (°С) воздуха в августе и ноябре. В ответе записываем только целую часть — 28.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями