Задание №4463. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия: – в строке все числа различны; – утроенное произведение минимального и максимального чисел строки не больше, чем удвоенное произведение трёх её оставшихся чисел. В ответе запишите только число.

Задание №4463.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке все числа различны;

– утроенное произведение минимального и максимального чисел строки не больше, чем удвоенное произведение трёх её оставшихся чисел.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

count = 0

with open('input.txt') as numbers:
    numbers = numbers.read().splitlines()
    for line in numbers:
        line = sorted([int(i) for i in line.split('\t')])
        
        if len(line) == len(set(line)) and line[0] * line[-1] * 3 <= line[1] * line[2] * line[3] * 2:
            count += 1
    print(count)

Таким образом, 9829 строк таблицы соответствуют указанным в задании условиям.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями