Задание №4479. Исполнитель Редактор получает на вход строку символов и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов. А) заменить (v, w). Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды заменить(111, 27) преобразует строку 05111150 в строку 0527150. Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку. Б) нашлось (v). Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется. Цикл &nbsp;&nbsp;&nbsp;&nbsp;ПОКА условие &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;последовательность команд &nbsp;&nbsp;&nbsp;&nbsp;КОНЕЦ ПОКА выполняется, пока условие истинно. В конструкции &nbsp;&nbsp;&nbsp;&nbsp;ЕСЛИ условие &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ТО команда1 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ИНАЧЕ команда2 &nbsp;&nbsp;&nbsp;&nbsp;КОНЕЦ ЕСЛИ выполняется команда1 (если условие истинно) или команда2 (если условие ложно). Дана программа для Редактора: НАЧАЛО ПОКА нашлось (72) ИЛИ нашлось (522) ИЛИ нашлось (2222) &nbsp;&nbsp;&nbsp;&nbsp;ЕСЛИ нашлось (72) &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ТО заменить (72, 2) &nbsp;&nbsp;&nbsp;&nbsp;КОНЕЦ ЕСЛИ &nbsp;&nbsp;&nbsp;&nbsp;ЕСЛИ нашлось (522) &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ТО заменить (522, 27) &nbsp;&nbsp;&nbsp;&nbsp;КОНЕЦ ЕСЛИ &nbsp;&nbsp;&nbsp;&nbsp;ЕСЛИ нашлось (2222) &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ТО заменить (2222, 5) &nbsp;&nbsp;&nbsp;&nbsp;КОНЕЦ ЕСЛИ КОНЕЦ ПОКА КОНЕЦ На вход приведённой выше программе поступает строка, начинающаяся с цифры «5», а затем содержащая n цифр «2» (3 < n < 10 000). Определите наименьшее значение n, при котором сумма цифр в строке, получившейся в результате выполнения программы, равна 66.

Задание №4479.
Исполнение алгоритма для конкретного исполнителя. ЕГЭ по информатике

Исполнитель Редактор получает на вход строку символов и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить(111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w)

не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

Цикл

    ПОКА условие
        последовательность команд
    КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

    ЕСЛИ условие
        ТО команда1
        ИНАЧЕ команда2
    КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

Дана программа для Редактора:

НАЧАЛО
ПОКА нашлось (72) ИЛИ нашлось (522) ИЛИ нашлось (2222)
    ЕСЛИ нашлось (72)
        ТО заменить (72, 2)
    КОНЕЦ ЕСЛИ
    ЕСЛИ нашлось (522)
         ТО заменить (522, 27)
    КОНЕЦ ЕСЛИ
    ЕСЛИ нашлось (2222)
         ТО заменить (2222, 5)
    КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ

На вход приведённой выше программе поступает строка, начинающаяся с цифры «5», а затем содержащая n цифр «2» (3 < n < 10 000).

Определите наименьшее значение n, при котором сумма цифр в строке, получившейся в результате выполнения программы, равна 66.

Пояснение:
Решим задание, написав программу на языке программирования Python.

for n in range(4,10000):
    k = '5' + '2'*n

    while '72' in k or '522' in k or '2222' in k:
        if '72' in k:
            k = k.replace('72', '2', 1)
        if '522' in k:
            k = k.replace('522', '27', 1)
        if '2222' in k:
            k = k.replace('2222', '5', 1)
    if sum(map(int, k)) == 66:
        print(n)
        break

Таким образом, 484 — наименьшее значение n, при котором сумма цифр в строке, получившейся в результате выполнения программы, равна 66.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями