Задание №4480. Исполнитель Редактор получает на вход строку символов и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов. А) заменить (v, w). Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды заменить(111, 27) преобразует строку 05111150 в строку 0527150. Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку. Б) нашлось (v). Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется. Цикл     ПОКА условие         последовательность команд     КОНЕЦ ПОКА выполняется, пока условие истинно. В конструкции     ЕСЛИ условие         ТО команда1         ИНАЧЕ команда2     КОНЕЦ ЕСЛИ выполняется команда1 (если условие истинно) или команда2 (если условие ложно). Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 82 идущих подряд цифр 1? В ответе запишите полученную строку. НАЧАЛО ПОКА нашлось (11111) ИЛИ нашлось (888)     ЕСЛИ нашлось (11111)         ТО заменить (11111, 88)     ИНАЧЕ         ЕСЛИ нашлось (888)             ТО заменить (888, 8)         КОНЕЦ ЕСЛИ     КОНЕЦ ЕСЛИ КОНЕЦ ПОКА КОНЕЦ

Задание №4480.
Исполнение алгоритма для конкретного исполнителя. ЕГЭ по информатике

Исполнитель Редактор получает на вход строку символов и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить(111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w)

не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

Цикл

    ПОКА условие
        последовательность команд
    КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

    ЕСЛИ условие
        ТО команда1
        ИНАЧЕ команда2
    КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 82 идущих подряд цифр 1? В ответе запишите полученную строку.

НАЧАЛО
ПОКА нашлось (11111) ИЛИ нашлось (888)
    ЕСЛИ нашлось (11111)
        ТО заменить (11111, 88)
    ИНАЧЕ
        ЕСЛИ нашлось (888)
            ТО заменить (888, 8)
        КОНЕЦ ЕСЛИ
    КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ

Пояснение:
Решим задание, написав программу на языке программирования Python.

line = '1' * 82

while '11111' in line or '888' in line:
    if '11111' in line:
        line = line.replace('11111', '88', 1)
    if '888' in line:
        line = line.replace('888', '8', 1)
        
print(line)

Таким образом, в результате применения приведённой ниже программы к строке, состоящей из 82 идущих подряд цифр 1, получится строка 8811.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями