Задание №4487. Значение арифметического выражения: 4 ∙ 6251920 + 4 ∙ 1251930 – 4 ∙ 251940 – 3 ∙ 51950 – 1960 записали в системе счисления с основанием 5. Определите количество значащих нулей в записи этого числа.

Задание №4487.
Позиционные системы счисления. ЕГЭ по информатике

Значение арифметического выражения:

4 ∙ 6251920 + 4 ∙ 1251930 – 4 ∙ 251940 – 3 ∙ 51950 – 1960

записали в системе счисления с основанием 5. Определите количество значащих нулей в записи этого числа.

Пояснение:
Решим задание, написав программу на языке программирования Python.

n = 4 * 625 ** 1920 + 4 * 125 ** 1930 - 4 * 25 ** 1940 - 3 * 5 ** 1950 - 1960
count = 0
while n:
    if n % 5 == 0:
        count += 1
    n //= 5
print(count)

Таким образом, 1891 значащих нулей содержится в этой записи.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями