Задание №4488. Значение арифметического выражения: 7 · 51219 + 6418 – 5 · 817 – 16 записали в системе счисления с основанием 8. Сколько цифр 7 содержится в этой записи?


Задание №4488.
Позиционные системы счисления. ЕГЭ по информатике

Значение арифметического выражения:

7 · 51219 + 6418 – 5 · 817 – 16

записали в системе счисления с основанием 8. Сколько цифр 7 содержится в этой записи?

Пояснение:
Решим задание, написав программу на языке программирования Python.

n = 7 * 512 ** 19 + 64 ** 18 - 5 * 8 ** 17 - 16
count = 0
while n:
    if n % 8 == 7:
        count += 1
    n //= 8
print(count)

Таким образом, 34 цифры 7 содержится в этой записи.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями