Задание №4489. Значение арифметического выражения: 6 ∙ 512395 + 7 ∙ 64396 + 3 ∙ 8398 + 5 ∙ 8393 + 300 записали в системе счисления с основанием 64. Сколько значащих нулей содержится в этой записи?


Задание №4489.
Позиционные системы счисления. ЕГЭ по информатике

Значение арифметического выражения:

6 ∙ 512395 + 7 ∙ 64396 + 3 ∙ 8398 + 5 ∙ 8393 + 300

записали в системе счисления с основанием 64. Сколько значащих нулей содержится в этой записи?

Пояснение:
Решим задание, написав программу на языке программирования Python.

n = 6 * 512 ** 395 + 7 * 64 ** 396 + 3 * 8 ** 398 + 5 * 8 ** 393 + 300
count = 0
while n:
    if n % 64 == 0:
        count += 1
    n //= 64
print(count)

Таким образом, 587 значащих нулей содержится в этой записи.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями