Задание №4490. Операнды арифметического выражения записаны в системе счисления с основанием 19. 98x7973119 + 36x1419 В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 18. Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.


Задание №4490.
Позиционные системы счисления. ЕГЭ по информатике

Операнды арифметического выражения записаны в системе счисления с основанием 19.

98x7973119 + 36x1419

В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 18.

Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Пояснение:
Решим задание, написав программу на языке программирования Python.

all_digits_19 = '0123456789ABCDEFGHI'

final = []
for x in all_digits_19:
    f = int(f"98{x}79731", 19) + int(f"36{x}14", 19)
    if f % 18 == 0:
        print(f"x = {x}, {f} / 18 = {f // 18}")

Таким образом, при x = 7 частное от деления значения арифметического выражения на 18 будет равно 468886479.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями