Задание №4491. Операнды арифметического выражения записаны в системе счисления с основанием 22. 98x7964122 + 36x1422 + 73x422 В записи чисел переменной x обозначена неизвестная цифра из алфавита 22-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 21. Для найденного x вычислите частное от деления значения арифметического выражения на 21 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Задание №4491.
Позиционные системы счисления. ЕГЭ по информатике

Операнды арифметического выражения записаны в системе счисления с основанием 22.

98x7964122 + 36x1422 + 73x422

В записи чисел переменной x обозначена неизвестная цифра из алфавита 22-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 21.

Для найденного x вычислите частное от деления значения арифметического выражения на 21 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Пояснение:
Решим задание, написав программу на языке программирования Python.

all_digits_22 = '0123456789ABCDEFGHIJKL'

final = []
for x in all_digits_22:
    f = int(f"98{x}79641", 22) + int(f"36{x}14", 22) + int(f"73{x}4", 22)
    if f % 21 == 0:
        print(f"x = {x}, {f} / 21 = {f // 21}")

Таким образом, при x = I частное от деления значения арифметического выражения на 21 будет равно 1116743619.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями