Задание №4492. Операнды арифметического выражения записаны в системе счисления с основанием 19. 78x7964319 + 25x4319 + 63x519 В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 18. Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.


Задание №4492.
Позиционные системы счисления. ЕГЭ по информатике

Операнды арифметического выражения записаны в системе счисления с основанием 19.

78x7964319 + 25x4319 + 63x519

В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 18.

Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Пояснение:
Решим задание, написав программу на языке программирования Python.

all_digits_19 = '0123456789ABCDEFGHI'

final = []
for x in all_digits_19:
    f = int(f"78{x}79643", 19) + int(f"25{x}43", 19) + int(f"63{x}5", 19)
    if f % 18 == 0:
        print(f"x = {x}, {f} / 18 = {f // 18}")

Таким образом, при x = 0 частное от деления значения арифметического выражения на 18 будет равно 368599039.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями