Задание №4493. Для какого наибольшего целого неотрицательного числа А выражение (x > A) ∨ (y > A) ∨ (y < x − 2) ∨ (y > 2x − 10) тождественно истинно, т.е. принимает значение 1 при любых целых положительных x и y?

Задание №4493.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наибольшего целого неотрицательного числа А выражение

(x > A) ∨ (y > A) ∨ (y < x − 2) ∨ (y > 2x − 10)

тождественно истинно, т.е. принимает значение 1 при любых целых положительных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in reversed(range(1000)):
    if all((x > a) or (y > a) or (y < x - 2) or (y > 2 * x - 10) for x in range(1, 100) for y in range(1, 100)):
        print(a)
        break

Таким образом, 7 — наибольшее целое неотрицательное число А, для которого представленное в задании выражение тождественно истинно при любых целых положительных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями