Задание №4494. Для какого наибольшего целого неотрицательного числа А логическое выражение (2x + y ≠ 80) ∨ (x < y) ∨ (A < x) истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?


Задание №4494.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наибольшего целого неотрицательного числа А логическое выражение

(2x + y ≠ 80) ∨ (x < y) ∨ (A < x)

истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in reversed(range(1000)):
    if all((2 * x + y != 80) or (x < y) or (a < x) for x in range(100) for y in range(100)):
        print(a)
        break

Таким образом, 26 — наибольшее целое неотрицательное число А, для которого представленное в задании выражение тождественно истинно при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями