Задание №4495. Для какого наибольшего целого неотрицательного числа А выражение (x · y > A) ∨ (x > y) ∨ (8 ≥ x) тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Задание №4495.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наибольшего целого неотрицательного числа А выражение

(x · y > A) ∨ (x > y) ∨ (8 ≥ x)

тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in reversed(range(1000)):
    if all((x * y > a) or (x > y) or (8 >= x) for x in range(100) for y in range(100)):
        print(a)
        break

Таким образом, 80 — наибольшее целое неотрицательное число А, для которого представленное в задании выражение тождественно истинно при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями