Задание №4496. Для какого наибольшего целого неотрицательного числа A выражение (y + 3x > A) ∨ (x < 20) ∨ (y < 20) тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Задание №4496.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наибольшего целого неотрицательного числа A выражение

(y + 3x > A) ∨ (x < 20) ∨ (y < 20)

тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in reversed(range(1000)):
    if all((y + 3 * x > a) or (x < 20) or (y < 20) for x in range(100) for y in range(100)):
        print(a)
        break

Таким образом, 79 — наибольшее целое неотрицательное число А, для которого представленное в задании выражение тождественно истинно при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями