Задание №4497. Для какого наибольшего целого неотрицательного числа А выражение (99 ≠ y + 2x) ∨ (A < x) ∨ (A < y) тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

Задание №4497.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наибольшего целого неотрицательного числа А выражение

(99 ≠ y + 2x) ∨ (A < x) ∨ (A < y)

тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in reversed(range(1000)):
    if all((99 != y + 2 * x) or (a < x) or (a < y) for x in range(100) for y in range(100)):
        print(a)
        break

Таким образом, 32 — наибольшее целое неотрицательное число А, для которого представленное в задании выражение тождественно истинно при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями