Задание №4498. Для какого наименьшего целого неотрицательного числа А выражение (x < A) ∨ (y < A) ∨ (x + 2y > 40) тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Задание №4498.
Основные понятия и законы математической логики. ЕГЭ по информатике

Для какого наименьшего целого неотрицательного числа А выражение

(x < A) ∨ (y < A) ∨ (x + 2y > 40)

тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in range(1000):
    if all((x < a) or (y < a) or (x + 2 * y > 40) for x in range(100) for y in range(100)):
        print(a)
        break

Таким образом, 14 — наименьшее целое неотрицательное число А, для которого представленное в задании выражение тождественно истинно при любых целых неотрицательных x и y.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями