Задание №4499. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = 6 при n < 7; F(n) = n + F(n − 1), если n ≥ 7. Чему равно значение выражения F(2023) – F(2021)?


Задание №4499.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = 6 при n < 7;

F(n) = n + F(n − 1), если n ≥ 7.

Чему равно значение выражения F(2023) – F(2021)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

import sys
sys.setrecursionlimit(2050)

def f(n):
    if n < 7:
        return 6
    else:
        return n + f(n - 1)
print(f(2023) - f(2021))

Таким образом, значение выражения F(2023) – F(2021) равно 4045.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями