Задание №4500. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = 10 при n < 11; F(n) = n + F(n − 1), если n ≥ 11. Чему равно значение выражения F(2024) – F(2021)?

Задание №4500.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = 10 при n < 11;

F(n) = n + F(n − 1), если n ≥ 11.

Чему равно значение выражения F(2024) – F(2021)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

import sys
sys.setrecursionlimit(2050)

def f(n):
    if n < 11:
        return 10
    else:
        return n + f(n - 1)
print(f(2024) - f(2021))

Таким образом, значение выражения F(2024) – F(2021) равно 6069.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями