Задание №4502. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = 3 при n < 3; F(n) = n + F(n − 2), если n ≥ 3. Чему равно значение выражения F(2022) – F(2018)?


Задание №4502.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = 3 при n < 3;

F(n) = n + F(n − 2), если n ≥ 3.

Чему равно значение выражения F(2022) – F(2018)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

import sys
sys.setrecursionlimit(2050)

def f(n):
    if n < 3:
        return 3
    else:
        return n + f(n-2)
print(f(2022) - f(2018))

Таким образом, значение выражения F(2022) – F(2018) равно 4042.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями