Задание №4503. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = 1 при n = 1; F(n) = n + F(n − 1), если n > 1. Чему равно значение выражения F(2023) – F(2020)?

Задание №4503.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = 1 при n = 1;

F(n) = n + F(n − 1), если n > 1.

Чему равно значение выражения F(2023) – F(2020)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

import sys
sys.setrecursionlimit(2050)

def f(n):
    if n == 1:
        return 1
    else:
        return n + f(n-1)
print(f(2023) - f(2020))

Таким образом, значение выражения F(2023) – F(2020) равно 6066.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями