Задание №4504. Алгоритм вычисления значения функции F(n), где n – целое неотрицательное число, задан следующими соотношениями: F(n) = 0 при n ≤ 1; F(n) = 2 · n + F(n − 1), если n > 1 и при этом n нечётно; F(n) = 2 · F(n − 1) , если n > 1 и при этом n чётно. Чему равно значение функции F(24)?

Задание №4504.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – целое неотрицательное число, задан следующими соотношениями:

F(n) = 0 при n ≤ 1;

F(n) = 2 · n + F(n − 1), если n > 1 и при этом n нечётно;

F(n) = 2 · F(n − 1) , если n > 1 и при этом n чётно.

Чему равно значение функции F(24)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(n):
    if n <= 1:
        return 0
    elif n > 1 and n % 2 != 0:
        return 2 * n + f(n - 1)
    else:
        return 2 * f(n - 1)
print(f(24))

Таким образом, значение функции F(24) равно 40852.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями