Задание №4505. Файл, необходимый для выполнения задания: ссылка для скачивания. В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых хотя бы одно число делится на минимальный элемент последовательности, кратный 21. Гарантируется, что такой элемент в последовательности есть. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.


Задание №4505.
Составление алгоритма обработки числовой последовательности. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых хотя бы одно число делится на минимальный элемент последовательности, кратный 21. Гарантируется, что такой элемент в последовательности есть.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Пояснение:
Решим задание, написав программу на языке программирования Python.

with open('input.txt') as numbers: # в аргументе необходимо указать путь к файлу

    numbers = [int(i) for i in numbers.read().splitlines()]

    final = []

    min_number = min([i for i in numbers if i % 21 == 0])

    for x in range(len(numbers)-1):
        if numbers[x] % min_number == 0 or numbers[x+1] % min_number == 0:
            final.append((numbers[x], numbers[x+1]))

print(len(final), max(sum(i) for i in final))

Таким образом, 126 — количество найденных пар чисел, а 171120 — максимальная из сумм элементов таких пар.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями