Задание №4510. Файл, необходимый для выполнения задания: ссылка для скачивания. В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых хотя бы один из элементов является трёхзначным числом, а сумма элементов пары кратна минимальному трёхзначному элементу последовательности, оканчивающемуся на 5. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Задание №4510.
Составление алгоритма обработки числовой последовательности. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых хотя бы один из элементов является трёхзначным числом, а сумма элементов пары кратна минимальному трёхзначному элементу последовательности, оканчивающемуся на 5.

В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Пояснение:
Решим задание, написав программу на языке программирования Python.

with open('input.txt', encoding='utf8') as numbers: # в первом аргументе указывается путь к файлу

    final = []

    numbers = numbers.read().splitlines()

    min_number = min([int(i) for i in numbers if i[-1] == '5' and len(i) == 3])

    for x in range(len(numbers)-2):
        two_numbers = [numbers[x], numbers[x+1]]
        three_digit_numbers = [i for i in two_numbers if len(i) == 3]

        if len(three_digit_numbers) > 0 and sum(int(i) for i in two_numbers) % min_number == 0:
            final.append((int(numbers[x]), int(numbers[x+1])))

print(len(final), max(sum(i) for i in final))

Таким образом, 13 — количество найденных пар чисел, а 9500 — максимальная из сумм элементов таких пар.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями