Задание №4517. Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или четыре камня либо увеличить количество камней в куче в три раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 103. Победителем считается игрок, сделавший последний ход, т.е. первым получивший кучу, состоящую из 103 или более камней. В начальный момент в куче было S камней; 1 ≤ S ≤ 102. Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Задание №4517.
Анализ алгоритма логической игры. ЕГЭ по информатике

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или четыре камня либо увеличить количество камней в куче в три раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда количество камней в куче становится не менее 103.

Победителем считается игрок, сделавший последний ход, т.е. первым получивший кучу, состоящую из 103 или более камней.

В начальный момент в куче было S камней; 1 ≤ S ≤ 102.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def game(s, move_counter):
    if move_counter == 2 and s >= 103: return 0
    elif move_counter == 3 and s >= 103: return 1
    elif move_counter == 3 and s < 103: return 0
    else:
        if move_counter % 2 != 0:
            return game(s + 1, move_counter + 1) and game(s + 4, move_counter + 1) and game(s * 3, move_counter + 1)
        else:
            return game(s + 1, move_counter + 1) or game(s + 4, move_counter + 1) or game(s * 3, move_counter + 1)

for s in range(1,103):
    if game(s, 1) == 1:
        print(s)

Таким образом, при S = 34 Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями