Задание №4541. Исполнитель преобразует число на экране. У исполнителя есть три команды, которым присвоены номера: A. Прибавить 1 B. Прибавить 3 C. Умножить на 3 Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 3 результатом является число 20, при этом траектория вычислений содержит число 14 и не содержит 15? Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 21, 24, 25.

Задание №4541.
Анализ хода исполнения алгоритма. ЕГЭ по информатике

Исполнитель преобразует число на экране.

У исполнителя есть три команды, которым присвоены номера:

A. Прибавить 1

B. Прибавить 3

C. Умножить на 3

Программа для исполнителя – это последовательность команд.

Сколько существует программ, для которых при исходном числе 3 результатом является число 20, при этом траектория вычислений содержит число 14 и не содержит 15?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы.

Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 21, 24, 25.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(x, y):
    if x > y or x == 15: return 0
    if x == y: return 1
    return f(x + 1, y) + f(x + 3, y) + f(x * 3, y)

print(f(3, 14) * f(14,20))

Таким образом, существует 92 программы, для которых при исходном числе 3 результатом является число 20, при этом траектория вычислений содержит число 14 и не содержит 15.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями