Задание №4542. Исполнитель преобразует число на экране. У исполнителя есть три команды, которым присвоены номера: A. Прибавить 2 B. Прибавить 3 C. Умножить на 2 Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 3 результатом является число 25, при этом траектория вычислений содержит число 10 и не содержит 17? Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 14, 17, 19.

Задание №4542.
Анализ хода исполнения алгоритма. ЕГЭ по информатике

Исполнитель преобразует число на экране.

У исполнителя есть три команды, которым присвоены номера:

A. Прибавить 2

B. Прибавить 3

C. Умножить на 2

Программа для исполнителя – это последовательность команд.

Сколько существует программ, для которых при исходном числе 3 результатом является число 25, при этом траектория вычислений содержит число 10 и не содержит 17?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы.

Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 14, 17, 19.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(x, y):
    if x > y or x == 17: return 0
    if x == y: return 1
    return f(x + 2, y) + f(x + 3, y) + f(x * 2, y)

print(f(3, 10) * f(10,25))

Таким образом, существует 90 программ, для которых при исходном числе 3 результатом является число 25, при этом траектория вычислений содержит число 10 и не содержит 17.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями