Задание №4546. Исполнитель преобразует число на экране. У исполнителя есть три команды, которым присвоены номера: A. Прибавить 1 B. Прибавить 2 C. Умножить на 2 Программа для исполнителя – это последовательность команд. Сколько существует программ, для которых при исходном числе 3 результатом является число 18, при этом траектория вычислений содержит число 8 и не содержит 13? Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 14, 16, 17.

Задание №4546.
Анализ хода исполнения алгоритма. ЕГЭ по информатике

Исполнитель преобразует число на экране.

У исполнителя есть три команды, которым присвоены номера:

A. Прибавить 1

B. Прибавить 2

C. Умножить на 2

Программа для исполнителя – это последовательность команд.

Сколько существует программ, для которых при исходном числе 3 результатом является число 18, при этом траектория вычислений содержит число 8 и не содержит 13?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы.

Например, для программы CBA при исходном числе 7 траектория будет состоять из чисел 14, 16, 17.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(x, y):
    if x > y or x == 13: return 0
    if x == y: return 1
    return f(x + 1, y) + f(x + 2, y) + f(x * 2, y)

print(f(3, 8) * f(8,18))

Таким образом, существует 308 программ, для которых при исходном числе 3 результатом является число 18, при этом траектория вычислений содержит число 8 и не содержит 13.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями