Задание №4547. Файл, необходимый для выполнения задания: ссылка для скачивания. Текстовый файл состоит из символов A, B и C. Определите максимальное количество идущих подряд пар символов CA или CB в прилагаемом файле. Искомая подпоследовательность должна состоять только из пар CA, или только из пар CB, или только из пар CA и CB в произвольном порядке следования этих пар. Для выполнения этого задания следует написать программу.

Задание №4547.
Создание собственной программы. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Текстовый файл состоит из символов A, B и C.

Определите максимальное количество идущих подряд пар символов CA или CB в прилагаемом файле.

Искомая подпоследовательность должна состоять только из пар CA, или только из пар CB, или только из пар CA и CB в произвольном порядке следования этих пар.

Для выполнения этого задания следует написать программу.

Пояснение:
Решим задание, написав программу на языке программирования Python.

with open('24_220.txt', encoding='utf8') as text_file:
    text_file = text_file.read()
    max_pairs = 0
    count_pairs = 0
    i = 0
    while i <= len(text_file)-1:
        if text_file[i:i+2] == 'CA' or text_file[i:i+2] == 'CB':
            count_pairs += 1
            i += 2
        else:
            if max_pairs < count_pairs:
                max_pairs = count_pairs
            count_pairs = 0
            i += 1
    print(max_pairs)

Таким образом, 78 — максимальное количество идущих подряд пар символов CA или CB в прилагаемом файле.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями