Задание №4553. Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы: 1) символ «?» означает ровно одну произвольную цифру; 2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность. Например, маске 123*4?5 соответствуют числа 123405 и 12300405. Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 123*678, делящиеся на 13 без остатка. В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 13.


Задание №4553.
Создание собственной программы. ЕГЭ по информатике

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

1) символ «?» означает ровно одну произвольную цифру;

2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 123*678, делящиеся на 13 без остатка.

В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 13.

Пояснение:
Решим задание, написав программу на языке программирования Python.

for x in range(13, 10 ** 8 + 1, 13):
    s = str(x)
    if s[0:3] == '123' and s[-3:] == '678':
        print(s, int(s) // 13)

Таким образом, получаем

Найденные
числа

Результаты
их деления
на 13

123767895206
12300678946206
12313678947206
12326678948206
12339678949206
12352678950206
12365678951206
12378678952206
12391678953206


Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями