Задание №4554. Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы: 1) символ «?» означает ровно одну произвольную цифру; 2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность. Например, маске 123*4?5 соответствуют числа 123405 и 12300405. Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 12??15*6, делящиеся на 253 без остатка. В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 253.


Задание №4554.
Создание собственной программы. ЕГЭ по информатике

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

1) символ «?» означает ровно одну произвольную цифру;

2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 12??15*6, делящиеся на 253 без остатка.

В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 253.

Пояснение:
Решим задание, написав программу на языке программирования Python.

for x in range(253, 10 ** 8 + 1, 253):
    s = str(x)
    if s[0:2] == '12' and s[4:6] == '15' and s[-1] == '6':
        print(s, int(s) // 253)

Таким образом, получаем

Найденные
числа

Результаты
их деления
на 253

12781565052
1253159649532
1274158650362
1295157651192


Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями