Задание №4556. Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы: 1) символ «?» означает ровно одну произвольную цифру; 2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность. Например, маске 123*4?5 соответствуют числа 123405 и 12300405. Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 1234*67, делящиеся на 19 без остатка. В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 19.

Задание №4556.
Создание собственной программы. ЕГЭ по информатике

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

1) символ «?» означает ровно одну произвольную цифру;

2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 1234*67, делящиеся на 19 без остатка.

В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие им результаты деления этих чисел на 19.

Пояснение:
Решим задание, написав программу на языке программирования Python.

for x in range(19, 10 ** 8 + 1, 19):
    s = str(x)
    if s[0:4] == '1234' and s[-2:] == '67':
        print(s, int(s) // 19)

Таким образом, получаем

Найденные
числа

Результаты
их деления
на 19

123486764993
12340367649493
12342267649593
12344167649693
12346067649793
12347967649893
12349867649993


Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями