Задание №4558. Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы: 1) символ «?» означает ровно одну произвольную цифру; 2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность. Например, маске 123*4?5 соответствуют числа 123405 и 12300405. Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 3?1*57, делящиеся на 2023 без остатка. В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие результаты деления этих чисел на 2023.

Задание №4558.
Создание собственной программы. ЕГЭ по информатике

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

1) символ «?» означает ровно одну произвольную цифру;

2) символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 3?1*57, делящиеся на 2023 без остатка.

В ответе сначала запишите все найденные числа в порядке возрастания, а затем – соответствующие результаты деления этих чисел на 2023.

Пояснение:
Решим задание, написав программу на языке программирования Python.

for x in range(2023, 10 ** 8 + 1, 2023):
    s = str(x)
    if s[0] == '3' and s[2] == '1' and s[-2:] == '57':
        print(s, int(s) // 2023)

Таким образом, получаем

Найденные
числа

Результаты
их деления
на 2023

321657159
3410575716859
3511725717359
3612875717859
3714025718359
3815175718859
3916325719359


Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями