Задание №4578. Все пятибуквенные слова, в составе которых могут быть только русские буквы П, А, Р, У, С, записаны в алфавитном порядке и пронумерованы начиная с 1. Ниже приведено начало списка. 1. ААААА 2. ААААП 3. ААААР 4. ААААС 5. ААААУ 6. АААПА … Под каким номером в списке идёт последнее слово, которое содержит не более одной буквы У и не содержит букв А, стоящих рядом?

Задание №4578.
Измерение количества информации. ЕГЭ по информатике

Все пятибуквенные слова, в составе которых могут быть только русские буквы П, А, Р, У, С, записаны в алфавитном порядке и пронумерованы начиная с 1.

Ниже приведено начало списка.
1. ААААА
2. ААААП
3. ААААР
4. ААААС
5. ААААУ
6. АААПА
…

Под каким номером в списке идёт последнее слово, которое содержит не более одной буквы У и не содержит букв А, стоящих рядом?

Пояснение:
Решим задание, написав программу на языке программирования Python.

from itertools import product

collection = sorted(list(''.join(i) for i in product('ПАРУС', repeat=5)))

count = len(collection)

collection.reverse()

for line in collection:
    if line.count('У') < 2 and all(line[i] != line[i+1] for i in range(len(line)-1) if line[i] == 'А'):
        print(count)
        break
    count -= 1

Таким образом, под номером 2969 в списке идёт последнее слово, которое содержит не более одной буквы У и не содержит букв А, стоящих рядом.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями