Задание №4579. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия: – наибольшее из четырёх чисел меньше суммы трёх других; – четыре числа можно разбить на две пары чисел с равными суммами. В ответе запишите только число.

Задание №4579.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– наибольшее из четырёх чисел меньше суммы трёх других;

– четыре числа можно разбить на две пары чисел с равными суммами.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

count = 0

with open('input.txt') as numbers:
    numbers = numbers.read().splitlines()
    for line in numbers:
        line = sorted([int(i) for i in line.split('\t')])

        if line[0] + line[1] == line[2] + line[3] or line[0] + line[2] == line[1] + line[3] or line[0] + line[3] == line[1] + line[2]:
            equal_sums = True
        else:
            equal_sums = False

        if line[-1] < sum(line[0:3]) and equal_sums:
            count += 1
    print(count)

Таким образом, 118 строк таблицы соответствуют указанным в задании условиям.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями