Задание №4582. Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр. А) заменить (v, w). Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды заменить(111, 27) преобразует строку 05111150 в строку 0527150. Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку. Б) нашлось (v). Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется. Цикл     ПОКА условие         последовательность команд     КОНЕЦ ПОКА выполняется, пока условие истинно. В конструкции     ЕСЛИ условие         ТО команда1         ИНАЧЕ команда2     КОНЕЦ ЕСЛИ выполняется команда1 (если условие истинно) или команда2 (если условие ложно). Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 82 идущих подряд цифр 8? В ответе запишите полученную строку. НАЧАЛО ПОКА нашлось (1111) ИЛИ нашлось (8888)     ЕСЛИ нашлось (1111)         ТО заменить (1111, 8)         ИНАЧЕ заменить (8888, 11)     КОНЕЦ ЕСЛИ КОНЕЦ ПОКА КОНЕЦ

Задание №4582.
Исполнение алгоритма для конкретного исполнителя. ЕГЭ по информатике

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить(111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w)

не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

Цикл

    ПОКА условие
        последовательность команд
    КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

    ЕСЛИ условие
        ТО команда1
        ИНАЧЕ команда2
    КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 82 идущих подряд цифр 8? В ответе запишите полученную строку.

НАЧАЛО
ПОКА нашлось (1111) ИЛИ нашлось (8888)
    ЕСЛИ нашлось (1111)
        ТО заменить (1111, 8)
        ИНАЧЕ заменить (8888, 11)
    КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ

Пояснение:
Решим задание, написав программу на языке программирования Python.

line = '8' * 82

while '1111' in line or '8888' in line:
    if '1111' in line:
        line = line.replace('1111', '8', 1)
    else:
        line = line.replace('8888', '11', 1)
        
print(line)

Таким образом, в результате применения приведённой ниже программы к строке, состоящей из 82 идущих подряд цифр 8, получится строка 118.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями