Задание №4584. Определите количество цифр с числовым значением, превышающим 9, в 27-ричной записи числа, заданного выражением: 2 ∙ 7292014 + 2 ∙ 2432016 – 2 ∙ 812018 + 2 ∙ 272020 – 2 ∙ 9 2022 – 2024.


Задание №4584.
Позиционные системы счисления. ЕГЭ по информатике

Определите количество цифр с числовым значением, превышающим 9, в 27-ричной записи числа, заданного выражением:

2 ∙ 7292014 + 2 ∙ 2432016 – 2 ∙ 812018 + 2 ∙ 272020 – 2 ∙ 9 2022 – 2024.


Пояснение:
Решим задание, написав программу на языке программирования Python.

n = 2 * 729 ** 2014 + 2 * 243 ** 2016 - 2 * 81 ** 2018 + 2 * 27 ** 2020 - 2 * 9 ** 2022 - 2024
count = 0
while n:
    if n % 27 > 9:
        count += 1
    n //= 27
print(count)

Таким образом, в 27-ричной записи числа 2687 цифр с числовым значением, превышающим 9.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями