Задание №4585. Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа А логическое выражение ¬ДЕЛ(x, А) → (ДЕЛ(x, 14) → ¬ДЕЛ(x, 4)) истинно (т.е. принимает значение 1) при любом целом положительном значении переменной х?

Задание №4585.
Основные понятия и законы математической логики. ЕГЭ по информатике

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наибольшего натурального числа А логическое выражение

¬ДЕЛ(x, А) → (ДЕЛ(x, 14) → ¬ДЕЛ(x, 4))

истинно (т.е. принимает значение 1) при любом целом положительном значении переменной х?

Пояснение:
Решим задание, написав программу на языке программирования Python.

for a in reversed(range(1000)):
    if all(not(not x % a == 0) or (not (x % 14 == 0) or not x % 4 == 0) for x in range(1, 100)):
        print(a)
        break

Таким образом, 28 — наибольшее натуральное число А, для которого представленное в задании выражение тождественно истинно при любых целых положительных значениях x.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями