Задание №4589. Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в два раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней. Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 59. Победителем считается игрок, сделавший последний ход, т.е. первым получивший такую позицию, при которой в кучах оказывается 59 или больше камней. В начальный момент в первой куче было пять камней, во второй куче – S камней; 1 ≤ S ≤ 53. Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, при котором такая ситуация возможна.

Задание №4589.
Анализ алгоритма логической игры. ЕГЭ по информатике

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в два раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 59. Победителем считается игрок, сделавший последний ход, т.е. первым получивший такую позицию, при которой в кучах оказывается 59 или больше камней.

В начальный момент в первой куче было пять камней, во второй куче – S камней; 1 ≤ S ≤ 53.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, при котором такая ситуация возможна.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def game(s1, s2, move_counter):
    if move_counter == 2 and s1 + s2 >= 59: return 0
    elif move_counter == 3 and s1 + s2 >= 59: return 1
    elif move_counter == 3 and s1 + s2 < 59: return 0
    else:
        return game(s1 + 1, s2, move_counter + 1) or game(s1 * 2, s2, move_counter + 1) or game(s1, s2 + 1, move_counter + 1) or game(s1, s2 * 2, move_counter + 1)

final = []
for s2 in range(1,54):
    if game(5, s2, 1) == 1:
        final.append(s2)
print(min(final))

Таким образом, 14 — минимальное значение S, когда такая ситуация возможна.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями