Задание №4593. Исполнитель преобразует число, записанное на экране. У исполнителя есть три команды, которые обозначены латинскими буквами: A. Прибавить 1 B. Прибавить 2 C. Умножить на 2 Программа для исполнителя – это последовательность команд. Сколько существует программ, которые преобразуют исходное число 4 в число 15, и при этом траектория вычислений программы содержит числа 11 и 13? Траектория должна содержать оба указанных числа. Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы ACB при исходном числе 7 траектория будет состоять из чисел 8, 16, 18.

Задание №4593.
Анализ хода исполнения алгоритма. ЕГЭ по информатике

Исполнитель преобразует число, записанное на экране. У исполнителя есть три команды, которые обозначены латинскими буквами:

A. Прибавить 1
B. Прибавить 2
C. Умножить на 2


Программа для исполнителя – это последовательность команд.

Сколько существует программ, которые преобразуют исходное число 4 в число 15, и при этом траектория вычислений программы содержит числа 11 и 13? Траектория должна содержать оба указанных числа.

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы.

Например, для программы ACB при исходном числе 7 траектория будет состоять из чисел 8, 16, 18.

Пояснение:
Решим задание, написав программу на языке программирования Python.

def f(x, y):
    if x > y: return 0
    if x == y: return 1
    return f(x + 1, y) + f(x + 2, y) + f(x * 2, y)

print(f(4, 11) * f(11, 13) * f(13, 15))

Таким образом, существует 100 программ, которые преобразуют исходное число 4 в число 15, и при этом траектория вычислений программы содержит числа 11 и 13.

Показать ответ

Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями