Задание №5125. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет. Пример работы программы: Входные данныеВыходные данные13 154 56 034.5269 5 0NO

Задание №5125.
Создание программы на универсальном языке программирования. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности).

Количество чисел не превышает 100. Введённые числа не превышают 300.

Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.

Пример работы программы:

Входные данныеВыходные данные
13
154
56
0
34.5
269
5
0
NO


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

two_digit_numbers = []

number = int(input())
while number != 0:
    if number > 9 and number < 100:
        two_digit_numbers.append(number)
    number = int(input())

if two_digit_numbers:
    sum_of_the_numbers = 0
    for number in two_digit_numbers:
        sum_of_the_numbers += number
    arithmetic_mean = sum_of_the_numbers / len(two_digit_numbers)
    print(arithmetic_mean)
else:
    print("NO")


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями