Задание №5126. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу для решения следующей задачи. Участники парусной регаты стартовали одновременно. На финише фиксировалось время прохождения маршрута каждой яхтой (в часах и минутах). Определите время победителя регаты (в часах и минутах). Известно, что соревнования проходили в течение 12 часов. Программа получает на вход количество яхт, принимавших участие в регате N (1 ≤ N ≤ 100), затем для каждой яхты вводится два числа: часы и минуты, затраченные на прохождение маршрута. Пример работы программы: Входные данныеВыходные данные2 3 25 2 502 50

Задание №5126.
Создание программы на универсальном языке программирования. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу для решения следующей задачи.

Участники парусной регаты стартовали одновременно. На финише фиксировалось время прохождения маршрута каждой яхтой (в часах и минутах). Определите время победителя регаты (в часах и минутах). Известно, что соревнования проходили в течение 12 часов.

Программа получает на вход количество яхт, принимавших участие в регате N (1 ≤ N ≤ 100), затем для каждой яхты вводится два числа: часы и минуты, затраченные на прохождение маршрута.

Пример работы программы:

Входные данныеВыходные данные
2
3 25
2 50
2 50


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Python:

number_of_yachts = int(input())

yachts_time = []

for yacht in (range(number_of_yachts)):
    hours, minutes = map(int, input().split())
    yachts_time.append((hours, minutes))

best_yacht_time_in_minutes = 0
index_of_the_best_yacht = 0

for x in range(len(yachts_time)):
    yacht_time_in_minutes = (yachts_time[x][0] * 60) + yachts_time[x][1]

    if x == 0:
        best_yacht_time_in_minutes, index_of_the_best_yacht = yacht_time_in_minutes, x
    else:
        if best_yacht_time_in_minutes > yacht_time_in_minutes:
            best_yacht_time_in_minutes, index_of_the_best_yacht = yacht_time_in_minutes, x

print(f"{yachts_time[index_of_the_best_yacht][0]} {yachts_time[index_of_the_best_yacht][1]}")


Источник: ФИПИ. Открытый банк тестовых заданий
Сообщить об ошибке


Тест с похожими заданиями