Задание №5128. Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4, но не кратных 7. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и не кратное 7. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 4, но не кратных 7. Пример работы программы: Входные данныеВыходные данные4 16 28 26 242

Задание №5128.
Создание программы на универсальном языке программирования. ОГЭ по информатике

Задание выполняется на компьютере. Результатом выполнения задания является отдельный файл.

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4, но не кратных 7. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и не кратное 7.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число: количество чисел, кратных 4, но не кратных 7.

Пример работы программы:

Входные данныеВыходные данные
4
16
28
26
24
2


Пояснение:
Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:

var n, i, a, k: integer;
    begin
    readln(n);
    k := 0;
    for i := 1 to n do
    begin
        readln(a);
        if (a mod 4 = 0) and (a mod 7 <> 0) then k := k + 1;
    end;
    writeln(k)
end.


Возможны и другие варианты решения.

Для проверки правильности работы программы необходимо использовать следующие тесты.

Входные данныеВыходные данные
13
4
7
28
1
24
28
16
4
24
3
35
24
28
4
44
2
3


Источник: Демонстрационная версия ОГЭ–2023
Сообщить об ошибке


Тест с похожими заданиями