Задание №6084. Файл, необходимый для выполнения задания: ссылка для скачивания. Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия: – в строке все числа различны; – сумма двух наибольших чисел строки не больше суммы трёх её оставшихся чисел. В ответе запишите только число.

Задание №6084.
Обработка числовой информации в электронных таблицах. ЕГЭ по информатике

Файл, необходимый для выполнения задания: ссылка для скачивания.

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия:

– в строке все числа различны;

– сумма двух наибольших чисел строки не больше суммы трёх её оставшихся чисел.

В ответе запишите только число.

Пояснение:
Приведем решение данного задания на языке программирования Python. Для этого необходимо скопировать содержимое Excel файла в текстовый документ с расширением .txt.

count = 0

with open('input.txt') as numbers:
    numbers = numbers.read().splitlines()
    for line in numbers:
        line = sorted([int(i) for i in line.split('\t')])
        
        if len(line) == len(set(line)) and sum([line[3], line[4]]) <= sum(line[0:3]):
            count += 1
    print(count)

Таким образом, 1922 строки таблицы соответствуют указанным в задании условиям.

Показать ответ

Источник: Открытый вариант — 2025
Сообщить об ошибке


Тест с похожими заданиями