Задание №6090. Обозначим через m & n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14 & 5 = 11102 & 01012 = 01002 = 4. Для какого наименьшего неотрицательного целого числа А логическое выражение ((x & 52 ≠ 0) ∧ (x & 48 = 0)) → ¬(x & А = 0) истинно (т.е. принимает значение 1) при любом неотрицательном целом значении переменной х?

Задание №6090.
Основные понятия и законы математической логики. ЕГЭ по информатике

Обозначим через m & n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14 & 5 = 11102 & 01012 = 01002 = 4.

Для какого наименьшего неотрицательного целого числа А логическое выражение

((x & 52 ≠ 0) ∧ (x & 48 = 0)) → ¬(x & А = 0)

истинно (т.е. принимает значение 1) при любом неотрицательном целом значении переменной х?

Пояснение:
Решим задание, написав программу на языке программирования Python.

def bitwise_conjunction(m, n):
    '''
    функция принимает два десятичных числа,
    производит поразрядную конъюнкцию (читайте
    условие задания) и возвращает десятичное
    число
    '''
    binary_m = bin(m)[2:]
    binary_n = bin(n)[2:]

    if len(binary_m) > len(binary_n):
        difference = len(binary_m) - len(binary_n)
        binary_n = '0' * difference + binary_n
    elif len(binary_n) > len(binary_m):
        difference = len(binary_n) - len(binary_m)
        binary_m = '0' * difference + binary_m

    binary_result = ''
    for m_digit, n_digit in zip(binary_m, binary_n):
        if int(m_digit) and int(n_digit):
            binary_result += '1'
        else:
            binary_result += '0'

    return int(binary_result, 2)

for a in range(1000):
    if all(not((bitwise_conjunction(x, 52) != 0) and (bitwise_conjunction(x, 48) == 0)) or not(bitwise_conjunction(x, a) == 0) for x in range(100)):
        print(a)
        break

Таким образом, 4 — наименьшее неотрицательное целое число А, при ктором логическое выражение истинно (т.е. принимает значение 1) при любом неотрицательном целом значении переменной х.

Показать ответ

Источник: Открытый вариант — 2025
Сообщить об ошибке


Тест с похожими заданиями