Задание №6091. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = n при n ≥ 2025; F(n) = n · 2 + F(n + 2), если n < 2025. Чему равно значение выражения F(82) – F(81)?

Задание №6091.
Вычисление рекуррентных выражений. ЕГЭ по информатике

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = n при n ≥ 2025;

F(n) = n · 2 + F(n + 2), если n < 2025.

Чему равно значение выражения F(82) – F(81)?

Пояснение:
Решим задание, написав программу на языке программирования Python.

import sys
sys.setrecursionlimit(2050)

def f(n):
    if n >= 2025:
        return n
    else:
        return (n * 2) + f(n+2)
print(f(82)-f(81))

Таким образом, значение выражения F(82) – F(81) равно 1945.

Показать ответ

Источник: Открытый вариант — 2025
Сообщить об ошибке


Тест с похожими заданиями